<!DOCTYPE html><html lang=en-US prefix="og: http://ogp.me/ns#"><head ><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><title>How to forward port using iptables in Linux - Kernel Talks</title><meta name=google-site-verification content=jeFc7PXM8ZxDY5awb8nCCD5-bYwj5S7bwsAIgp1JIgU><meta name=msvalidate.01 content=920806CD9A79B08EC8477C0D440658A4><meta name=p:domain_verify content=738d0b16e329ab01cc894a68d2adda34><meta name=yandex-verification content=bd079834c4df4ebf><meta name=description content="Quick article to demonstrate how to configure port forwarding in Linux using iptables."><link rel=canonical href=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/><link rel=publisher href=https://plus.google.com/115086199909589647244/115086199909589647244><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="How to forward port using iptables in Linux - Kernel Talks"><meta property=og:description content="Quick article to demonstrate how to configure port forwarding in Linux using iptables."><meta property=og:url content=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/><meta property=og:site_name content="Kernel Talks"><meta property=article:publisher content=https://facebook.com/kerneltalks><meta property=article:author content=https://www.facebook.com/kerneltalks/><meta property=article:tag content="how to foward port"><meta property=article:tag content="iptables port forwarding"><meta property=article:tag content="Port forwarding in linux"><meta property=article:section content=Networking><meta property=article:published_time content=2019-02-28T09:08:17+00:00><meta property=article:modified_time content=2019-03-01T06:55:37+00:00><meta property=og:updated_time content=2019-03-01T06:55:37+00:00><meta property=og:image content="https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?fit=512%2C256&#038;ssl=1"><meta property=og:image:secure_url content="https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?fit=512%2C256&#038;ssl=1"><meta property=og:image:width content=512><meta property=og:image:height content=256><meta property=og:image:alt content="Port forwarding using iptables"><meta name=twitter:card content=summary_large_image><meta name=twitter:description content="Quick article to demonstrate how to configure port forwarding in Linux using iptables."><meta name=twitter:title content="How to forward port using iptables in Linux - Kernel Talks"><meta name=twitter:site content=@kerneltalks><meta name=twitter:image content="https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?fit=512%2C256&#038;ssl=1"><meta name=twitter:creator content=@kerneltalks> <script type=application/ld+json>{"@context":"https://schema.org","@type":"Person","url":"https://kerneltalks.com/","sameAs":["https://facebook.com/kerneltalks","https://plus.google.com/115086199909589647244/115086199909589647244","https://twitter.com/kerneltalks"],"@id":"#person","name":"Shrikant Lavhate"}</script> <link rel=amphtml href=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/amp/><link rel=dns-prefetch href=//s0.wp.com><link rel=dns-prefetch href=//pagead2.googlesyndication.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="Kernel Talks &raquo; Feed" href=https://kerneltalks.com/feed/><link rel=alternate type=application/rss+xml title="Kernel Talks &raquo; Comments Feed" href=https://kerneltalks.com/comments/feed/><link rel=alternate type=application/rss+xml title="Kernel Talks &raquo; How to forward port using iptables in Linux Comments Feed" href=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/feed/><link rel=stylesheet id=crayon-theme-dark-terminal-css  href=https://c1.kerneltalks.com/wp-content/plugins/crayon-syntax-highlighter/themes/dark-terminal/dark-terminal.css type=text/css media=all><link rel=stylesheet type=text/css href=https://c1.kerneltalks.com/wp-content/cache/minify/c96e8.css media=all><link rel=stylesheet id=wpProQuiz_front_style-css  href=https://c1.kerneltalks.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css type=text/css media=all><link rel=stylesheet id=dashicons-css  href=https://c1.kerneltalks.com/wp-includes/css/dashicons.min.css type=text/css media=all><link rel=stylesheet id=google-fonts-css  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.1' type=text/css media=all><link rel=stylesheet type=text/css href=https://c1.kerneltalks.com/wp-content/cache/minify/454ca.css media=all> <script>if(document.location.protocol!="https:"){document.location=document.URL.replace(/^http:/i,"https:");}</script><script>var SDT_DATA={"ajaxurl":"https:\/\/kerneltalks.com\/wp-admin\/admin-ajax.php","siteUrl":"https:\/\/kerneltalks.com\/","pluginsUrl":"https:\/\/kerneltalks.com\/wp-content\/plugins","isAdmin":""};</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/445b5.js></script> <!--[if lt IE 9]> <script src=https://c2.kerneltalks.com/wp-content/themes/genesis/lib/js/html5shiv.min.js></script> <![endif]--> <script async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=2.8.1'></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-8607025047420953",enable_page_level_ads:true,tag_partner:"genesis"});</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/27163.js></script> <link rel=https://api.w.org/ href=https://kerneltalks.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=https://kerneltalks.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://c2.kerneltalks.com/wp-includes/wlwmanifest.xml><link rel=shortlink href='https://kerneltalks.com/?p=4247'><link rel=alternate type=application/json+oembed href="https://kerneltalks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkerneltalks.com%2Fnetworking%2Fhow-to-forward-port-using-iptables-in-linux%2F"><link rel=alternate type=text/xml+oembed href="https://kerneltalks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkerneltalks.com%2Fnetworking%2Fhow-to-forward-port-using-iptables-in-linux%2F&#038;format=xml"><link rel=dns-prefetch href=//v0.wordpress.com><link rel=dns-prefetch href=//i0.wp.com><link rel=dns-prefetch href=//i1.wp.com><link rel=dns-prefetch href=//i2.wp.com><style>img#wpstats{display:none}</style><link rel=dns-prefetch href=//c1.kerneltalks.com><link rel=dns-prefetch href=//c2.kerneltalks.com><link rel=dns-prefetch href=//c3.kerneltalks.com><link rel=dns-prefetch href=//c4.kerneltalks.com><style>.site-title a{background:url(https://c1.kerneltalks.com/wp-content/uploads/2017/09/kerneltalks_logo.png) no-repeat !important}</style><style>.upcoming-events li{margin-bottom:10px}.upcoming-events li span{display:block}</style><meta name=onesignal content=wordpress-plugin><link rel=manifest href="https://c2.kerneltalks.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="> <script src=https://cdn.onesignal.com/sdks/OneSignalSDK.js async></script> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("https://kerneltalks.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='419cab1a-27d3-4428-82fd-db5280876f57';oneSignal_options['autoRegister']=true;oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['welcomeNotification']['url']="https://kerneltalks.com";oneSignal_options['path']="https://kerneltalks.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";oneSignal_options['safari_web_id']="web.onesignal.auto.3cda868c-95ba-4dc0-a9c6-5ad5b099bc53";oneSignal_options['persistNotification']=false;oneSignal_options['promptOptions']={};OneSignal.init(window._oneSignalInitOptions);});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script> <link rel=icon href="https://i1.wp.com/kerneltalks.com/wp-content/uploads/2017/09/cropped-Fevicon.png?fit=32%2C32&#038;ssl=1" sizes=32x32><link rel=icon href="https://i1.wp.com/kerneltalks.com/wp-content/uploads/2017/09/cropped-Fevicon.png?fit=192%2C192&#038;ssl=1" sizes=192x192><link rel=apple-touch-icon-precomposed href="https://i1.wp.com/kerneltalks.com/wp-content/uploads/2017/09/cropped-Fevicon.png?fit=180%2C180&#038;ssl=1"><meta name=msapplication-TileImage content="https://i1.wp.com/kerneltalks.com/wp-content/uploads/2017/09/cropped-Fevicon.png?fit=270%2C270&#038;ssl=1"><style id=wp-custom-css>@media only screen and (min-width:769px){section#search-3.widget.widget_search{display:none !important}}.nav-secondary .responsive-menu-icon::after{content:"Explore";font-size:14px;position:relative;font-family:'Raleway',sans-serif;top:-3px;display:inline-block}@media only screen and (min-width: 769px){.genesis-nav-menu>.menu-item-has-children>a:after{content:"\f347";display:inline-block;-webkit-font-smoothing:antialiased;font:normal 16px/1 'dashicons';padding-left:3px;vertical-align:top}}</style></head><body data-rsssl=1 class="post-template-default single single-post postid-4247 single-format-standard custom-header header-image content-sidebar magazine-pro-orange primary-nav" itemscope itemtype=https://schema.org/WebPage><div class=site-container><nav class=nav-primary aria-label=Main itemscope itemtype=https://schema.org/SiteNavigationElement><div class=wrap><ul id=menu-menu class="menu genesis-nav-menu menu-primary"><li id=menu-item-54 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-54"><a href=https://kerneltalks.com/ itemprop=url><span itemprop=name>Home</span></a></li><li id=menu-item-189 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href=https://kerneltalks.com/disclaimer/ itemprop=url><span itemprop=name>Disclaimer</span></a></li><li id=menu-item-190 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-190"><a href=https://kerneltalks.com/contact/ itemprop=url><span itemprop=name>Contact</span></a></li><li id=menu-item-479 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-479"><a href=https://kerneltalks.com/archives/ itemprop=url><span itemprop=name>Archives</span></a></li><li id=menu-item-55 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55"><a href=https://kerneltalks.com/about/ itemprop=url><span itemprop=name>About</span></a></li><li id=menu-item-2295 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2295"><a href=https://kerneltalks.com/subscribe/ itemprop=url><span itemprop=name>Subscribe</span></a></li><li id=menu-item-1378 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1378"><a href=https://kerneltalks.com/buy-me-coffee/ itemprop=url><span itemprop=name>Support</span></a></li><li id=menu-item-3164 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3164"><a href=https://kerneltalks.com/advertise/ itemprop=url><span itemprop=name>Advertise</span></a></li><li class="right search"><form method=get class="searchform search-form" action=https://kerneltalks.com/search > <input type=text value="Search this site.." name=q class="s search-input" onfocus="if (this.value == 'Search this site..') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this site..';}"> <input type=submit class="searchsubmit search-submit" value=Search></form></li></ul></div></nav><header class=site-header itemscope itemtype=https://schema.org/WPHeader><div class=wrap><div class=title-area><p class=site-title itemprop=headline><a href=https://kerneltalks.com/>Kernel Talks</a></p><p class=site-description itemprop=description>Unix, Linux  &amp; scripts.</p></div><div class="widget-area header-widget-area"><section id=custom_html-4 class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-8607025047420953 data-ad-slot=8306670027 data-ad-format=auto></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id=search-3 class="widget widget_search"><div class=widget-wrap><form method=get class="searchform search-form" action=https://kerneltalks.com/search > <input type=text value="Search this site.." name=q class="s search-input" onfocus="if (this.value == 'Search this site..') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this site..';}"> <input type=submit class="searchsubmit search-submit" value=Search></form></div></section></div></div></header><nav class=nav-secondary aria-label=Secondary itemscope itemtype=https://schema.org/SiteNavigationElement><div class=wrap><ul id=menu-sec-menu class="menu genesis-nav-menu menu-secondary"><li id=menu-item-2704 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2704"><a href=# itemprop=url><span itemprop=name>How-to guides</span></a><ul class=sub-menu><li id=menu-item-2684 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2684"><a href=https://kerneltalks.com/category/howto/ itemprop=url><span itemprop=name>Howto</span></a></li><li id=menu-item-2685 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2685"><a href=https://kerneltalks.com/category/disk-management/ itemprop=url><span itemprop=name>Disk management</span></a></li><li id=menu-item-2686 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2686"><a href=https://kerneltalks.com/category/config/ itemprop=url><span itemprop=name>Configurations</span></a></li></ul></li><li id=menu-item-2705 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2705"><a href=# itemprop=url><span itemprop=name>OS</span></a><ul class=sub-menu><li id=menu-item-2682 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2682"><a href=https://kerneltalks.com/category/hpux/ itemprop=url><span itemprop=name>HPUX</span></a></li><li id=menu-item-2681 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2681"><a href=https://kerneltalks.com/category/linux/ itemprop=url><span itemprop=name>Linux</span></a></li></ul></li><li id=menu-item-2706 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2706"><a href=# itemprop=url><span itemprop=name>Commands &#038; tools</span></a><ul class=sub-menu><li id=menu-item-2689 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2689"><a href=https://kerneltalks.com/category/commands/ itemprop=url><span itemprop=name>Commands</span></a></li><li id=menu-item-2692 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2692"><a href=https://kerneltalks.com/category/tools/ itemprop=url><span itemprop=name>Software &#038; Tools</span></a></li><li id=menu-item-2691 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2691"><a href=https://kerneltalks.com/category/services/ itemprop=url><span itemprop=name>System services</span></a></li></ul></li><li id=menu-item-2711 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2711"><a href=# itemprop=url><span itemprop=name>Cloud computing</span></a><ul class=sub-menu><li id=menu-item-2712 class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2712"><a href=https://kerneltalks.com/cloud-services/aws-csa-associate-quiz/ itemprop=url><span itemprop=name>AWS CSA associate quiz</span></a></li><li id=menu-item-2713 class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2713"><a href=https://kerneltalks.com/virtualization/complete-aws-csa-associate-preparation-guide/ itemprop=url><span itemprop=name>AWS CSA preparation guide!</span></a></li><li id=menu-item-2687 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2687"><a href=https://kerneltalks.com/category/cloud-services/ itemprop=url><span itemprop=name>Cloud Services</span></a></li></ul></li><li id=menu-item-2688 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2688"><a href=https://kerneltalks.com/category/tips-tricks/ itemprop=url><span itemprop=name>Tips &#038; Tricks</span></a></li><li id=menu-item-2953 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2953"><a href=https://kerneltalks.com/useful-linux-commands-for-beginners/ itemprop=url><span itemprop=name>Linux commands</span></a></li></ul></div></nav><div class=site-inner><div class=content-sidebar-wrap><main class=content><div class=breadcrumb itemscope itemtype=https://schema.org/BreadcrumbList>You are here: <span class=breadcrumb-link-wrap itemprop=itemListElement itemscope itemtype=https://schema.org/ListItem><a class=breadcrumb-link href=https://kerneltalks.com/ itemprop=item><span class=breadcrumb-link-text-wrap itemprop=name>Home</span></a><meta itemprop=position content=1></span> <span aria-label="breadcrumb separator">/</span> <span class=breadcrumb-link-wrap itemprop=itemListElement itemscope itemtype=https://schema.org/ListItem><a class=breadcrumb-link href=https://kerneltalks.com/category/networking/ itemprop=item><span class=breadcrumb-link-text-wrap itemprop=name>Networking</span></a><meta itemprop=position content=2></span></div><article class="post-4247 post type-post status-publish format-standard has-post-thumbnail category-networking tag-how-to-foward-port tag-iptables-port-forwarding tag-port-forwarding-in-linux entry" itemscope itemtype=https://schema.org/CreativeWork><header class=entry-header><h1 class="entry-title" itemprop="headline">How to forward port using iptables in Linux</h1><p class=entry-meta>Published: <time class=entry-time itemprop=datePublished datetime=2019-02-28T14:38:17+05:30>February 28, 2019</time> | Modified: <time class=entry-modified-time itemprop=dateModified datetime=2019-03-01T12:25:37+05:30>March 1, 2019</time> | 234 views</p><style>.kt_text{width:290px;height:90px}@media(min-width: 500px){.kt_text{width:268px;height:40px}}@media(min-width: 800px){.kt_text{width:528px;height:20px}}</style> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class="adsbygoogle kt_text" style=display:inline-block data-ad-client=ca-pub-8607025047420953 data-ad-slot=3888649223 data-ad-format=link></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br><br></header><div class=entry-content itemprop=text><div class="share-before share-filled share-small" id=share-before-4247><div class=facebook id=facebook-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class=googlePlus id=googleplus-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class=twitter id=twitter-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Tweet data-reader="Tweet this" data-count="%s Tweets"></div><div class=linkedin id=linkedin-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div><div class=stumbleupon id=stumbleupon-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on StumbleUpon" data-count="%s shares on StumbleUpon"></div><div class=pinterest id=pinterest-before-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Pin data-reader="Pin this" data-count="%s Pins"></div></div> <script>jQuery(document).ready(function($){$('#facebook-before-4247').sharrre({share:{facebook:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('facebook');}});$('#googleplus-before-4247').sharrre({share:{googlePlus:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('googlePlus');}});$('#twitter-before-4247').sharrre({share:{twitter:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{twitter:{via:'kerneltalks'}},click:function(api,options){api.simulateClick();api.openPopup('twitter');}});$('#linkedin-before-4247').sharrre({share:{linkedin:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('linkedin');}});$('#stumbleupon-before-4247').sharrre({share:{stumbleupon:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('stumbleupon');}});$('#pinterest-before-4247').sharrre({share:{pinterest:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{pinterest:{media:'https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?fit=512%2C256&ssl=1',description:'How to forward port using iptables in Linux'}},click:function(api,options){api.simulateClick();api.openPopup('pinterest');}});});</script> <hr class=wp-block-separator><p style=text-align:center><em>Quick article to demonstrate how to configure port forwarding in Linux using iptables.</em></p><div class=wp-block-image><figure class=aligncenter><img src="https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?ssl=1" alt="Port forwarding using iptables" class=wp-image-4261 srcset="https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?w=512&amp;ssl=1 512w, https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 512px) 100vw, 512px" data-recalc-dims=1><figcaption>Port forwarding using iptables</figcaption></figure></div><hr class=wp-block-separator><p>In this article, we will walk you through port forwarding using <a href=https://kerneltalks.com/networking/basics-of-iptables-linux-firewall/>iptables</a> in Linux. First of all you need to check if port forwarding is enabled or not on your server. For better understanding, we will be using <code>eth0</code> as a reference interface and all our command executions will be related to <code>eth0</code> in this article.</p><h4>How to check if port forwarding is enabled in Linux</h4><p>Either you can use <code>sysctl</code> to check if forwarding is enabled or not. Use below command to check &#8211;</p><div class=8amydcAf style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style="display:block; text-align:center;" data-ad-format=fluid data-ad-layout=in-article data-ad-client=ca-pub-8607025047420953 data-ad-slot=4837837224></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div id=crayon-5c78d822653de420523465 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]#  sysctl -a |grep -i eth0.forwarding
net.ipv4.conf.eth0.forwarding = 0
net.ipv6.conf.eth0.forwarding = 0
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d822653de420523465-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653de420523465-2>2</div><div class=crayon-num data-line=crayon-5c78d822653de420523465-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653de420523465-4>4</div><div class=crayon-num data-line=crayon-5c78d822653de420523465-5>5</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d822653de420523465-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653de420523465-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c>#&nbsp;&nbsp;sysctl -a |grep -i eth0.forwarding</span></div><div class=crayon-line id=crayon-5c78d822653de420523465-3><span class=crayon-v>net</span><span class=crayon-e>.ipv4</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>0</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653de420523465-4><span class=crayon-v>net</span><span class=crayon-e>.ipv6</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>0</span></div><div class=crayon-line id=crayon-5c78d822653de420523465-5>&nbsp;</div></div></td></tr></table></div></div><p>Since both values are zero, port forwarding is disabled for ipv4 and ipv6 on interface eth0.</p><p>Or you can use process filesystem to check if port forwarding is enabled or not.</p><div id=crayon-5c78d822653ee376565008 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]# cat /proc/sys/net/ipv4/conf/eth0/forwarding
0
[root@kerneltalks ~]# cat /proc/sys/net/ipv6/conf/eth0/forwarding
0
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d822653ee376565008-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653ee376565008-2>2</div><div class=crayon-num data-line=crayon-5c78d822653ee376565008-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653ee376565008-4>4</div><div class=crayon-num data-line=crayon-5c78d822653ee376565008-5>5</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653ee376565008-6>6</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d822653ee376565008-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653ee376565008-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># cat /proc/sys/net/ipv4/conf/eth0/forwarding</span></div><div class=crayon-line id=crayon-5c78d822653ee376565008-3><span class=crayon-cn>0</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653ee376565008-4><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># cat /proc/sys/net/ipv6/conf/eth0/forwarding</span></div><div class=crayon-line id=crayon-5c78d822653ee376565008-5><span class=crayon-cn>0</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653ee376565008-6>&nbsp;</div></div></td></tr></table></div></div><p>Again here process FS with zero values confirms port forwarding is disabled on our system. Now we need  to first enable port forwarding on our system then we will configure port forwarding <a href=https://kerneltalks.com/networking/configuration-of-iptables-policies/>rules in iptables</a>.</p><hr class=wp-block-separator><h4>How to enable port forwarding in Linux</h4><p>As we checked above, using same both methods you can enable port forwarding in Linux. But its recommended to use <code>sysctl</code> command rather than replacing 0 by 1 in proc files.</p><p>Enable port forwarding in Linux using <code>sysctl</code> command &#8211;</p><div id=crayon-5c78d822653f4142163992 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]# sysctl net.ipv4.conf.eth0.forwarding=1
net.ipv4.conf.eth0.forwarding = 1
[root@kerneltalks ~]# sysctl net.ipv6.conf.eth0.forwarding=1
net.ipv6.conf.eth0.forwarding = 1
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d822653f4142163992-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653f4142163992-2>2</div><div class=crayon-num data-line=crayon-5c78d822653f4142163992-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653f4142163992-4>4</div><div class=crayon-num data-line=crayon-5c78d822653f4142163992-5>5</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d822653f4142163992-6>6</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d822653f4142163992-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653f4142163992-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># sysctl net.ipv4.conf.eth0.forwarding=1</span></div><div class=crayon-line id=crayon-5c78d822653f4142163992-3><span class=crayon-v>net</span><span class=crayon-e>.ipv4</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>1</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653f4142163992-4><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># sysctl net.ipv6.conf.eth0.forwarding=1</span></div><div class=crayon-line id=crayon-5c78d822653f4142163992-5><span class=crayon-v>net</span><span class=crayon-e>.ipv6</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>1</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d822653f4142163992-6>&nbsp;</div></div></td></tr></table></div></div><p>To make it persistent over reboots, add parameters in <code>/etc/sysctl.conf</code></p><div id=crayon-5c78d82265402967286663 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]# echo "net.ipv4.conf.eth0.forwarding = 1"&gt;&gt;/etc/sysctl.conf
[root@kerneltalks ~]# echo "net.ipv6.conf.eth0.forwarding = 1"&gt;&gt;/etc/sysctl.conf
[root@kerneltalks ~]# sysctl -p
net.ipv4.conf.eth0.forwarding = 1
net.ipv6.conf.eth0.forwarding = 1
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d82265402967286663-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265402967286663-2>2</div><div class=crayon-num data-line=crayon-5c78d82265402967286663-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265402967286663-4>4</div><div class=crayon-num data-line=crayon-5c78d82265402967286663-5>5</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265402967286663-6>6</div><div class=crayon-num data-line=crayon-5c78d82265402967286663-7>7</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d82265402967286663-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265402967286663-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># echo "net.ipv4.conf.eth0.forwarding = 1"&gt;&gt;/etc/sysctl.conf</span></div><div class=crayon-line id=crayon-5c78d82265402967286663-3><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># echo "net.ipv6.conf.eth0.forwarding = 1"&gt;&gt;/etc/sysctl.conf</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265402967286663-4><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># sysctl -p</span></div><div class=crayon-line id=crayon-5c78d82265402967286663-5><span class=crayon-v>net</span><span class=crayon-e>.ipv4</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>1</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265402967286663-6><span class=crayon-v>net</span><span class=crayon-e>.ipv6</span><span class=crayon-e>.conf</span><span class=crayon-e>.eth0</span><span class=crayon-e>.forwarding</span><span class=crayon-h> </span><span class=crayon-o>=</span><span class=crayon-h> </span><span class=crayon-cn>1</span></div><div class=crayon-line id=crayon-5c78d82265402967286663-7>&nbsp;</div></div></td></tr></table></div></div><p>Now, we have port forwarding enabled on our server, we can go ahead with configuring port forwarding rules using <code>iptables</code>.</p><hr class=wp-block-separator><h4>How to forward port in Linux</h4><p>Here we will forward port 80 to port 8080 on 172.31.40.29. Do not get confused port forwarding with <a href=https://kerneltalks.com/networking/how-to-redirect-port-in-linux-using-iptables/>port redirection.</a></p><p>We need to insert an entry in <code>PREROUTING</code> chain of <code>iptables</code> with <code>DNAT</code> target. Command will be as follows &#8211;</p><div id=crayon-5c78d82265408013111596 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

# iptables -A PREROUTING -t nat -i eth0 -p tcp --dport 80 -j DNAT --to 172.31.40.29:8080
# iptables -A FORWARD -p tcp -d 172.31.40.29 --dport 8080 -j ACCEPT
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d82265408013111596-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265408013111596-2>2</div><div class=crayon-num data-line=crayon-5c78d82265408013111596-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265408013111596-4>4</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d82265408013111596-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265408013111596-2><span class=crayon-c># iptables -A PREROUTING -t nat -i eth0 -p tcp --dport 80 -j DNAT --to 172.31.40.29:8080</span></div><div class=crayon-line id=crayon-5c78d82265408013111596-3><span class=crayon-c># iptables -A FORWARD -p tcp -d 172.31.40.29 --dport 8080 -j ACCEPT</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265408013111596-4>&nbsp;</div></div></td></tr></table></div></div><p>Change interface, ip and ports as per your requirement. First command tell to redirect packets coming to port 80 to IP 172.31.40.29 on port 8080. Now packet also needs to go through <code>FORWARD</code> chain so we are allowing in in second command.</p><p>Now rules have been applied. You need to verify them.</p><hr class=wp-block-separator><h4>How to check port forwarding iptables rules</h4><p>Command to verify port forwarding rules is &#8211;</p><div id=crayon-5c78d82265420442523814 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]# iptables -t nat -L -n -v
Chain PREROUTING (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 DNAT       tcp  --  eth0   *       0.0.0.0/0            0.0.0.0/0            tcp dpt:80 to:172.31.40.29:8080
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d82265420442523814-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265420442523814-2>2</div><div class=crayon-num data-line=crayon-5c78d82265420442523814-3>3</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265420442523814-4>4</div><div class=crayon-num data-line=crayon-5c78d82265420442523814-5>5</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265420442523814-6>6</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d82265420442523814-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265420442523814-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># iptables -t nat -L -n -v</span></div><div class=crayon-line id=crayon-5c78d82265420442523814-3><span class=crayon-e>Chain </span><span class=crayon-e>PREROUTING</span><span class=crayon-h> </span><span class=crayon-sy>(</span><span class=crayon-e>policy </span><span class=crayon-i>ACCEPT</span><span class=crayon-h> </span><span class=crayon-cn>0</span><span class=crayon-h> </span><span class=crayon-v>packets</span><span class=crayon-sy>,</span><span class=crayon-h> </span><span class=crayon-cn>0</span><span class=crayon-h> </span><span class=crayon-v>bytes</span><span class=crayon-sy>)</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265420442523814-4><span class=crayon-h> </span><span class=crayon-e>pkts </span><span class=crayon-e>bytes </span><span class=crayon-e>target&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-e>prot </span><span class=crayon-e>opt </span><span class=crayon-st>in</span><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-e>out&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-e>source&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-i>destination</span></div><div class=crayon-line id=crayon-5c78d82265420442523814-5><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp;</span><span class=crayon-cn>0</span><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-cn>0</span><span class=crayon-h> </span><span class=crayon-e>DNAT&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-v>tcp</span><span class=crayon-h>&nbsp;&nbsp;</span><span class=crayon-o>--</span><span class=crayon-h>&nbsp;&nbsp;</span><span class=crayon-v>eth0</span><span class=crayon-h>&nbsp;&nbsp; </span><span class=crayon-o>*</span><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class=crayon-cn>0.0.0.0</span><span class=crayon-o>/</span><span class=crayon-cn>0</span><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class=crayon-cn>0.0.0.0</span><span class=crayon-o>/</span><span class=crayon-cn>0</span><span class=crayon-h>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class=crayon-e>tcp </span><span class=crayon-v>dpt</span><span class=crayon-o>:</span><span class=crayon-cn>80</span><span class=crayon-h> </span><span class=crayon-st>to</span><span class=crayon-o>:</span><span class=crayon-cn>172.31.40.29</span><span class=crayon-o>:</span><span class=crayon-cn>8080</span></div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265420442523814-6>&nbsp;</div></div></td></tr></table></div></div><p>Here <code>REDIRECT</code> target means its a redirection rule. Since we have configured forwarding rule we see target as <code>DNAT</code></p><hr class=wp-block-separator><h4>How to save iptables rules</h4><p>To save <code>iptables</code> rules and make them persistent over reboots use below command &#8211;</p><div id=crayon-5c78d82265427547932846 class="crayon-syntax crayon-theme-dark-terminal crayon-font-courier-new crayon-os-pc print-yes notranslate" data-settings=" touchscreen minimize scroll-mouseover disable-anim" style=" margin-top: 12px; margin-bottom: 12px; font-size: 13px !important; line-height: 15px !important;"><div class=crayon-toolbar data-settings=" show" style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><span class=crayon-title></span><div class=crayon-tools style="font-size: 13px !important;height: 19.5px !important; line-height: 19.5px !important;"><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class=crayon-button-icon></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class=crayon-button-icon></div></div><span class=crayon-language>Shell</span></div></div><div class=crayon-info style="min-height: 18.2px !important; line-height: 18.2px !important;"></div><div class=crayon-plain-wrap><textarea wrap=soft class="crayon-plain print-no" data-settings=mouseover  style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 13px !important; line-height: 15px !important;">

[root@kerneltalks ~]# iptables-save
</textarea></div><div class=crayon-main style><table class=crayon-table><tr class=crayon-row><td class="crayon-nums " data-settings=hide><div class=crayon-nums-content style="font-size: 13px !important; line-height: 15px !important;"><div class=crayon-num data-line=crayon-5c78d82265427547932846-1>1</div><div class="crayon-num crayon-striped-num" data-line=crayon-5c78d82265427547932846-2>2</div><div class=crayon-num data-line=crayon-5c78d82265427547932846-3>3</div></div></td><td class=crayon-code><div class=crayon-pre style="font-size: 13px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class=crayon-line id=crayon-5c78d82265427547932846-1>&nbsp;</div><div class="crayon-line crayon-striped-line" id=crayon-5c78d82265427547932846-2><span class=crayon-sy>[</span><span class=crayon-v>root</span><span class=crayon-sy>@</span><span class=crayon-v>kerneltalks</span><span class=crayon-h> </span><span class=crayon-o>~</span><span class=crayon-sy>]</span><span class=crayon-c># iptables-save</span></div><div class=crayon-line id=crayon-5c78d82265427547932846-3>&nbsp;</div></div></td></tr></table></div></div></p><div class="share-after share-filled share-small" id=share-after-4247><div class=facebook id=facebook-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class=googlePlus id=googleplus-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class=twitter id=twitter-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Tweet data-reader="Tweet this" data-count="%s Tweets"></div><div class=linkedin id=linkedin-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div><div class=stumbleupon id=stumbleupon-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Share data-reader="Share on StumbleUpon" data-count="%s shares on StumbleUpon"></div><div class=pinterest id=pinterest-after-4247 data-url=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ data-urlalt="https://kerneltalks.com/?p=4247" data-text="How to forward port using iptables in Linux" data-title=Pin data-reader="Pin this" data-count="%s Pins"></div></div> <script>jQuery(document).ready(function($){$('#facebook-after-4247').sharrre({share:{facebook:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('facebook');}});$('#googleplus-after-4247').sharrre({share:{googlePlus:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('googlePlus');}});$('#twitter-after-4247').sharrre({share:{twitter:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{twitter:{via:'kerneltalks'}},click:function(api,options){api.simulateClick();api.openPopup('twitter');}});$('#linkedin-after-4247').sharrre({share:{linkedin:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('linkedin');}});$('#stumbleupon-after-4247').sharrre({share:{stumbleupon:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('stumbleupon');}});$('#pinterest-after-4247').sharrre({share:{pinterest:true},urlCurl:'https://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',enableHover:false,enableTracking:true,disableCount:true,buttons:{pinterest:{media:'https://i2.wp.com/kerneltalks.com/wp-content/uploads/2019/02/How-to-forward-port-using-iptables-in-Linux.png?fit=512%2C256&ssl=1',description:'How to forward port using iptables in Linux'}},click:function(api,options){api.simulateClick();api.openPopup('pinterest');}});});</script></div><div class=prev-next-navigation><div class=previous>&#8672 Previous article <br/> <a href=https://kerneltalks.com/scripts/script-to-create-mount-points-in-lvm/ rel=prev>Script to create mount points in LVM</a></div><div class=next> Next article &#8674<br/> <a href=https://kerneltalks.com/networking/how-to-redirect-port-in-linux-using-iptables/ rel=next>How to redirect port in Linux using iptables</a></div></div><div><h3>Related stuff:</h3><ul class=myrelated><li><a href=https://kerneltalks.com/networking/network-bonding-teaming-configuration-in-linux/ rel=bookmark title="Link to 4 step Network bonding / teaming configuration in Linux">4 step Network bonding / teaming configuration in Linux</a></li><li><a href=https://kerneltalks.com/networking/how-to-redirect-port-in-linux-using-iptables/ rel=bookmark title="Link to How to redirect port in Linux using iptables">How to redirect port in Linux using iptables</a></li><li><a href=https://kerneltalks.com/networking/configuration-of-iptables-policies/ rel=bookmark title="Link to Configuration of iptables policies">Configuration of iptables policies</a></li><li><a href=https://kerneltalks.com/networking/network-routes-in-linux/ rel=bookmark title="Link to Network routes in Linux">Network routes in Linux</a></li><li><a href=https://kerneltalks.com/networking/how-docker-container-dns-works/ rel=bookmark title="Link to How Docker container DNS works">How Docker container DNS works</a></li><li><a href=https://kerneltalks.com/networking/basics-of-iptables-linux-firewall/ rel=bookmark title="Link to Basics of iptables &#8211; Linux firewall">Basics of iptables &#8211; Linux firewall</a></li></ul></div><footer class=entry-footer><p class=entry-meta><span class=entry-categories>Filed Under: <a href=https://kerneltalks.com/category/networking/ rel="category tag">Networking</a></span> <span class=entry-tags>Tagged With: <a href=https://kerneltalks.com/tag/how-to-foward-port/ rel=tag>how to foward port</a>, <a href=https://kerneltalks.com/tag/iptables-port-forwarding/ rel=tag>iptables port forwarding</a>, <a href=https://kerneltalks.com/tag/port-forwarding-in-linux/ rel=tag>Port forwarding in linux</a></span></p><div class=mybox><style>.mybox{border:2px solid green;padding:20px;margin:5px;border-radius:15px;background-color:lightgrey}ul.belowpost{margin-left:30px}a.abelow{text-decoration:underline}</style><h4 class="belowposthead">If you like my tutorials and if they helped you in any way, then</h4><ul class=belowpost><li>Consider buying me <a class=abelow href=https://kerneltalks.com/buy-me-coffee/>a cup of coffee via paypal</a>!</li><li>Subscribe to our newsletter <a class=abelow href=https://eepurl.com/cDSMhj>here</a>!</li><li>Like KernelTalks <a class=abelow href=https://www.facebook.com/kerneltalks>Facebook page</a>.</li><li>Follow us on <a class=abelow href=https://twitter.com/@kerneltalks>Twitter</a>.</li><li>Follow our <a class=abelow href=https://plus.google.com/b/115086199909589647244/115086199909589647244>Google+ page</a>.</li><li>Add our <a class=abelow href=https://feeds.feedburner.com/kerneltalks>RSS feed</a> to your feed reader.</li></ul></div></footer></article><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Share Your Comments & Feedback: <small><a rel=nofollow id=cancel-comment-reply-link href=/networking/how-to-forward-port-using-iptables-in-linux/#respond style=display:none;>Cancel reply</a></small></h3><form action=https://kerneltalks.com/wp-comments-post.php method=post id=commentform class=comment-form novalidate><p class=comment-form-comment><label for=comment>Comment</label><textarea id=comment name=comment cols=45 rows=3 aria-required=true></textarea></p><p class=comment-form-author><label for=author>Name <span class=required>*</span></label> <input id=author name=author type=text value size=30 maxlength=245 required=required></p><p class=comment-form-email><label for=email>Email <span class=required>*</span></label> <input id=email name=email type=email value size=30 maxlength=100 aria-describedby=email-notes required=required></p><div class="gglcptch gglcptch_v2"><div id=gglcptch_recaptcha_334120553 class=gglcptch_recaptcha></div> <noscript><div style="width: 302px;"><div style="width: 302px; height: 422px; position: relative;"><div style="width: 302px; height: 422px; position: absolute;"> <iframe src="https://www.google.com/recaptcha/api/fallback?k=6LdkXzcUAAAAAEcGSulTV49A2mClJ3rIH6wLvaX1" frameborder=0 scrolling=no style="width: 302px; height:422px; border-style: none;"></iframe></div></div><div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;"><textarea id=g-recaptcha-response name=g-recaptcha-response class=g-recaptcha-response style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea></div></div> </noscript></div><p class=form-submit><input name=submit type=submit id=submit class=submit value="Post Comment"> <input type=hidden name=comment_post_ID value=4247 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=31e9f13613></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=96></p></form></div><p class=akismet_comment_form_privacy_notice>This site uses Akismet to reduce spam. <a href=https://akismet.com/privacy/ target=_blank rel="nofollow noopener">Learn how your comment data is processed</a>.</p></main><aside class="sidebar sidebar-primary widget-area" role=complementary aria-label="Primary Sidebar" itemscope itemtype=https://schema.org/WPSideBar><section id=simple-social-icons-2 class="widget simple-social-icons"><div class=widget-wrap><h4 class="widget-title widgettitle">Get fresh content from KernelTalks</h4><ul class=aligncenter><li class=ssi-email><a href=https://eepurl.com/cDSMhj target=_blank rel="noopener noreferrer"><svg role=img class=social-email aria-labelledby=social-email-2><title id=social-email-2>Email</title><use xlink:href=https://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email></use></svg></a></li><li class=ssi-facebook><a href=https://www.facebook.com/kerneltalks target=_blank rel="noopener noreferrer"><svg role=img class=social-facebook aria-labelledby=social-facebook-2><title id=social-facebook-2>Facebook</title><use xlink:href=https://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook></use></svg></a></li><li class=ssi-gplus><a href=https://plus.google.com/+kerneltalks target=_blank rel="noopener noreferrer"><svg role=img class=social-gplus aria-labelledby=social-gplus-2><title id=social-gplus-2>Google+</title><use xlink:href=https://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus></use></svg></a></li><li class=ssi-rss><a href=https://feeds.feedburner.com/kerneltalks target=_blank rel="noopener noreferrer"><svg role=img class=social-rss aria-labelledby=social-rss-2><title id=social-rss-2>RSS</title><use xlink:href=https://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss></use></svg></a></li><li class=ssi-twitter><a href=https://twitter.com/@kerneltalks target=_blank rel="noopener noreferrer"><svg role=img class=social-twitter aria-labelledby=social-twitter-2><title id=social-twitter-2>Twitter</title><use xlink:href=https://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter></use></svg></a></li></ul></div></section> <section id=custom_html-7 class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-8607025047420953 data-ad-slot=2693168428 data-ad-format=auto></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id=custom_html-8 class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-8607025047420953 data-ad-slot=8007133228></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id=top-posts-3 class="widget widget_top-posts"><div class=widget-wrap><h4 class="widget-title widgettitle">Popular posts</h4><ul><li> <a href=https://kerneltalks.com/networking/how-to-forward-port-using-iptables-in-linux/ class=bump-view data-bump-view=tp> How to forward port using iptables in Linux </a></li><li> <a href=https://kerneltalks.com/disk-management/how-to-rescan-disk-in-linux-after-extending-vmware-disk/ class=bump-view data-bump-view=tp> How to rescan disk in Linux after extending vmware disk </a></li><li> <a href=https://kerneltalks.com/troubleshooting/mount-nfs-requested-nfs-version-or-transport-protocol-is-not-supported/ class=bump-view data-bump-view=tp> mount.nfs: requested NFS version or transport protocol is not supported </a></li><li> <a href=https://kerneltalks.com/config/guide-smtp-configuration-linux/ class=bump-view data-bump-view=tp> 5 steps guide for SMTP configuration in Linux </a></li><li> <a href=https://kerneltalks.com/virtualization/how-to-reset-iptables-to-default-settings/ class=bump-view data-bump-view=tp> How to reset iptables to default settings </a></li><li> <a href=https://kerneltalks.com/linux/4-ways-to-check-size-of-physical-memory-in-linux/ class=bump-view data-bump-view=tp> 4 ways to check size of physical memory (RAM) in Linux </a></li><li> <a href=https://kerneltalks.com/howto/how-to-enable-repository-using-subscription-manager-in-rhel/ class=bump-view data-bump-view=tp> How to enable repository using subscription-manager in RHEL </a></li><li> <a href=https://kerneltalks.com/tips-tricks/how-to-configure-login-banners-in-linux/ class=bump-view data-bump-view=tp> How to configure login banners in Linux (RedHat, Ubuntu, CentOS, Fedora)					</a></li><li> <a href=https://kerneltalks.com/howto/how-to-setup-domain-name-in-linux-server/ class=bump-view data-bump-view=tp> How to setup domain name in Linux server </a></li><li> <a href=https://kerneltalks.com/troubleshooting/resolve-mount-nfs-stale-file-handle-error/ class=bump-view data-bump-view=tp> How to resolve mount.nfs: Stale file handle error </a></li></ul></div></section> <section id=custom_html-3 class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-8607025047420953 data-ad-slot=7776448985 data-ad-format=auto></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id=custom_html-6 class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><link href=//cdn-images.mailchimp.com/embedcode/classic-10_7.css rel=stylesheet type=text/css><style>#mc_embed_signup{background:#fff;clear:left;font:14px Helvetica,Arial,sans-serif}</style><div id=mc_embed_signup><form action="https://kerneltalks.us15.list-manage.com/subscribe/post?u=4ad15bb953ea2e9b9f4cd84fd&amp;id=c402c2fb30" method=post id=mc-embedded-subscribe-form name=mc-embedded-subscribe-form class=validate target=_blank novalidate><div id=mc_embed_signup_scroll><h2>Get Linux &amp; Unix stuff right into your mailbox. Subscribe now!</h2><div class=indicates-required><span class=asterisk>*</span> indicates required</div><div class=mc-field-group> <label for=mce-FNAME>Name </label> <input type=text value name=FNAME class id=mce-FNAME></div><div class=mc-field-group> <label for=mce-EMAIL>Email Address  <span class=asterisk>*</span> </label> <input type=email value name=EMAIL class="required email" id=mce-EMAIL></div><div id=mce-responses class=clear><div class=response id=mce-error-response style=display:none></div><div class=response id=mce-success-response style=display:none></div></div><div style="position: absolute; left: -5000px;" aria-hidden=true><input type=text name=b_4ad15bb953ea2e9b9f4cd84fd_c402c2fb30 tabindex=-1 value></div><div class=clear><input type=submit value=Subscribe name=subscribe id=mc-embedded-subscribe class=button></div></div></form></div></div></div></section> </aside></div></div><center> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-8607025047420953 data-ad-slot=4467072020 data-ad-format=auto></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </center><footer class=site-footer itemscope itemtype=https://schema.org/WPFooter><div class=wrap><p>This work is licensed under a <a href=https://creativecommons.org/licenses/by-nc/4.0/>CC-BY-NC</a> license &middot; <a href=https://kerneltalks.com/privacy-policy/>Privacy Policy</a>  <br>&copy; Copyright 2016-2017 <a href=https://kerneltalks.com/>KernelTalks</a> &middot; All Rights Reserved. <br>The content is copyrighted to Shrikant Lavhate & can not be reproduced either online or offline without prior permission.</p></div></footer><div class=fixedbar><div class=boxfloat><ul id=tips><li><a href=https://kerneltalks.com/user-management/how-to-remove-password-expiry-in-linux/>How to remove password expiry in linux</a></li><li><a href=https://kerneltalks.com/hpux/how-to-remove-password-expiry-in-hpux-hp-unix/>How to remove password expiry in HPUX HP Unix</a></li><li><a href=https://kerneltalks.com/virtualization/what-is-docker-introduction-guide-to-docker/>What is Docker? Introduction guide to Docker</a></li><li><a href=https://kerneltalks.com/other/new-kerneltalks-newsletters/>Mailchimp KernelTalks newsletters are here!</a></li><li><a href=https://kerneltalks.com/troubleshooting/how-to-unmount-nfs-when-server-is-offline/>How to unmount NFS when server is offline</a></li><li><a href=https://kerneltalks.com/howto/file-encryption-password-protect-file-hpux/>File encryption / password protect file in HPUX</a></li><li><a href=https://kerneltalks.com/virtualization/how-to-reset-iptables-to-default-settings/>How to reset iptables to default settings</a></li><li><a href=https://kerneltalks.com/tools/all-you-need-to-know-about-sosreport/>All you need to know about sosreport tool</a></li><li><a href=https://kerneltalks.com/commands/xfs-file-system-commands-with-examples/>xfs file system commands with examples</a></li><li><a href=https://kerneltalks.com/disk-management/lvm-commands-tutorial-vgcreate-vgdisplay-vgscan/>LVM commands tutorial : Part 2 : Volume group (vgcreate, vgdisplay, vgscan)</a></li></ul></div></div></div><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-85401996-1','auto');ga('send','pageview');</script> <style media=screen>#simple-social-icons-2 ul li a, #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus{background-color:#eee !important;border-radius:0px;color:#222 !important;border:0px #fff solid !important;font-size:28px;padding:14px}#simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus{background-color:#222 !important;border-color:#fff !important;color:#fff !important}#simple-social-icons-2 ul li a:focus{outline:1px dotted #222 !important}</style><link rel=stylesheet type=text/css href=https://c1.kerneltalks.com/wp-content/cache/minify/9fe08.css media=all> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/38215.js></script> <script>var wpcf7={"apiSettings":{"root":"https:\/\/kerneltalks.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/0fef6.js></script> <script src=https://s0.wp.com/wp-content/js/devicepx-jetpack.js></script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/69faf.js></script> <script>var q2w3_sidebar_options=[{"sidebar":"sidebar","margin_top":70,"margin_bottom":205,"stop_id":"ad_unit","screen_max_width":800,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["custom_html-6"]}];</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/10927.js></script> <script>var CrayonSyntaxSettings={"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/kerneltalks.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};var CrayonSyntaxStrings={"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/a8312.js></script> <script data-cfasync=false async=async defer=defer src='https://www.google.com/recaptcha/api.js?render=explicit&#038;ver=1.42'></script> <script>/*<![CDATA[*/var gglcptch={"options":{"version":"v2","sitekey":"6LdkXzcUAAAAAEcGSulTV49A2mClJ3rIH6wLvaX1","theme":"light","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly."},"vars":{"visibility":false}};/*]]>*/</script> <script src=https://c2.kerneltalks.com/wp-content/cache/minify/b3df2.js></script> <script src=https://stats.wp.com/e-201909.js async=async defer=defer></script> <script>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:7.0.1',blog:'118008198',post:'4247',tz:'5.5',srv:'kerneltalks.com'}]);_stq.push(['clickTrackerInit','118008198','4247']);</script> </body></html>