<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head ><meta charset="UTF-8" /><title>How to list open ports on Linux/Unix server - Kernel Talks</title><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="google-site-verification" content="jeFc7PXM8ZxDY5awb8nCCD5-bYwj5S7bwsAIgp1JIgU" /><meta name="msvalidate.01" content="920806CD9A79B08EC8477C0D440658A4" /><meta name="p:domain_verify" content="738d0b16e329ab01cc894a68d2adda34" /><meta name="yandex-verification" content="bd079834c4df4ebf" /><meta name="description" content="Learn to list all open ports on Linux or Unix system. Also view associated process with them. Handy tip to troubleshoot service connectivity issues."/><meta name="robots" content="noodp"/><link rel="canonical" href="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" /><link rel="publisher" href="https://plus.google.com/115086199909589647244/115086199909589647244"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to list open ports on Linux/Unix server - Kernel Talks" /><meta property="og:description" content="Learn to list all open ports on Linux or Unix system. Also view associated process with them. Handy tip to troubleshoot service connectivity issues." /><meta property="og:url" content="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" /><meta property="og:site_name" content="Kernel Talks" /><meta property="article:publisher" content="http://facebook.com/kerneltalks" /><meta property="article:tag" content="established ports in linux" /><meta property="article:tag" content="how to check listening ports in linux" /><meta property="article:tag" content="list all ports on server in linux" /><meta property="article:tag" content="open ports in unix" /><meta property="article:tag" content="open sockets in linux" /><meta property="article:section" content="Tips &amp; Tricks" /><meta property="article:published_time" content="2017-02-25T08:49:28+00:00" /><meta property="fb:admins" content="100011760153523" /><meta property="og:image" content="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png" /><meta property="og:image:width" content="200" /><meta property="og:image:height" content="200" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Learn to list all open ports on Linux or Unix system. Also view associated process with them. Handy tip to troubleshoot service connectivity issues." /><meta name="twitter:title" content="How to list open ports on Linux/Unix server - Kernel Talks" /><meta name="twitter:site" content="@kerneltalks" /><meta name="twitter:image" content="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png" /><meta name="twitter:creator" content="@kerneltalks" /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Kernel Talks &raquo; Feed" href="http://kerneltalks.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Kernel Talks &raquo; Comments Feed" href="http://kerneltalks.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Kernel Talks &raquo; How to list open ports on Linux/Unix server Comments Feed" href="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/kerneltalks.com\/wp-includes\/js\/wp-emoji-release.min.js"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link rel='stylesheet' id='crayon-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css' type='text/css' media='all' /><link rel='stylesheet' id='crayon-theme-dark-terminal-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/crayon-syntax-highlighter/themes/dark-terminal/dark-terminal.css' type='text/css' media='all' /><link rel='stylesheet' id='crayon-font-monaco-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/crayon-syntax-highlighter/fonts/monaco.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-simple-share-plugin-css-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/css/share.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-simple-share-genericons-css-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/css/genericons.css' type='text/css' media='all' /><link rel='stylesheet' id='magazine-pro-theme-css'  href='http://cdn2.kerneltalks.com/wp-content/themes/magazine-pro/style.css' type='text/css' media='all' /><link rel='stylesheet' id='awd-style-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/aryo-widget-device/assets/css/style.css' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='http://cdn2.kerneltalks.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.1' type='text/css' media='all' /><link rel='stylesheet' id='simple-social-icons-font-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/simple-social-icons/css/style.css' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://cdn2.kerneltalks.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' /> <script type="text/javascript" src="http://cdn1.kerneltalks.com/wp-content/cache/minify/df983.js"></script> <script type='text/javascript'>var CrayonSyntaxSettings={"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/kerneltalks.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};var CrayonSyntaxStrings={"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};</script> <script type="text/javascript" src="http://cdn1.kerneltalks.com/wp-content/cache/minify/8235f.js"></script> <!--[if lt IE 9]> <script type='text/javascript' src='http://cdn1.kerneltalks.com/wp-content/themes/genesis/lib/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='http://kerneltalks.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://kerneltalks.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cdn1.kerneltalks.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='http://kerneltalks.com/?p=1436' /><link rel="alternate" type="application/json+oembed" href="http://kerneltalks.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkerneltalks.com%2Ftips-tricks%2Flist-open-ports-linux-server%2F" /><link rel="alternate" type="text/xml+oembed" href="http://kerneltalks.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fkerneltalks.com%2Ftips-tricks%2Flist-open-ports-linux-server%2F&#038;format=xml" /><link rel='dns-prefetch' href='//v0.wordpress.com'><link rel='dns-prefetch' href='//jetpack.wordpress.com'><link rel='dns-prefetch' href='//s0.wp.com'><link rel='dns-prefetch' href='//s1.wp.com'><link rel='dns-prefetch' href='//s2.wp.com'><link rel='dns-prefetch' href='//public-api.wordpress.com'><link rel='dns-prefetch' href='//0.gravatar.com'><link rel='dns-prefetch' href='//1.gravatar.com'><link rel='dns-prefetch' href='//2.gravatar.com'><style type='text/css'>img#wpstats{display:none}</style><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-8607025047420953",enable_page_level_ads:true});</script> <style type="text/css">.site-title a{background:url(http://cdn2.kerneltalks.com/wp-content/uploads/2017/01/logo_image.png) no-repeat !important}</style><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#eee !important;border-radius:0px;color:#222 !important;border:0px #fff solid !important;font-size:19px;padding:10px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#222 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px dotted #222 !important}</style><link rel="icon" href="http://cdn1.kerneltalks.com/wp-content/uploads/2016/11/cropped-favicon-32x32.png" sizes="32x32" /><link rel="icon" href="http://cdn2.kerneltalks.com/wp-content/uploads/2016/11/cropped-favicon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="http://cdn1.kerneltalks.com/wp-content/uploads/2016/11/cropped-favicon-180x180.png" /><meta name="msapplication-TileImage" content="http://cdn1.kerneltalks.com/wp-content/uploads/2016/11/cropped-favicon-270x270.png" /><style type="text/css" id="wp-custom-css">.entry-tags{display:none}.entry-categories{display:none}.blog .entry-image-link{display:none}.blog .entry-comments-link{display:none}.archive-pagination li{margin-left:5px}.archive-pagination{text-align:center}.sharrre .share{color:#fff !important}ul.myrelated{margin-left:30px}ul.belowpost{margin-left:30px}a.abelow{text-decoration:underline}.home .mybox{display:none}.page .mybox{display:none}.mybox{border:2px solid green;padding:20px;margin:5px;border-radius:15px;background-color:lightgrey}a.entry-author-link{pointer-events:none;cursor:default}</style></head><body class="post-template-default single single-post postid-1436 single-format-standard custom-header header-image content-sidebar magazine-pro-orange primary-nav" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-54" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-54"><a href="http://kerneltalks.com/" itemprop="url"><span itemprop="name">Home</span></a></li><li id="menu-item-189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-189"><a href="http://kerneltalks.com/disclaimer/" itemprop="url"><span itemprop="name">Disclaimer</span></a></li><li id="menu-item-190" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-190"><a href="http://kerneltalks.com/contact/" itemprop="url"><span itemprop="name">Contact</span></a></li><li id="menu-item-479" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-479"><a href="http://kerneltalks.com/archives/" itemprop="url"><span itemprop="name">Archives</span></a></li><li id="menu-item-55" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55"><a href="http://kerneltalks.com/about/" itemprop="url"><span itemprop="name">About</span></a></li><li id="menu-item-1378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1378"><a href="http://kerneltalks.com/buy-me-coffee/" itemprop="url"><span itemprop="name">Buy me a coffee!</span></a></li><li class="right search"><form method="get" class="searchform search-form" action="http://kerneltalks.com/search" > <input type="text" value="Search this site.." name="q" class="s search-input" onfocus="if (this.value == 'Search this site..') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this site..';}" /> <input type="submit" class="searchsubmit search-submit" value="Search" /></form></li></ul></div></nav><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://kerneltalks.com/">Kernel Talks</a></p><p class="site-description" itemprop="description">Unix, Linux  &amp; scripts.</p></div><div class="widget-area header-widget-area"><section id="text-8" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><style>.kernel_header{width:290px;height:90px}@media(min-width: 500px){.kernel_header{width:468px;height:60px}}@media(min-width: 800px){.kernel_header{width:728px;height:90px}}</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle kernel_header" style="display:inline-block" data-ad-client="ca-pub-8607025047420953" data-ad-slot=1774838424"> data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></section><div class="awd-hidden-desktop"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="searchform search-form" action="http://kerneltalks.com/search" > <input type="text" value="Search this site.." name="q" class="s search-input" onfocus="if (this.value == 'Search this site..') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this site..';}" /> <input type="submit" class="searchsubmit search-submit" value="Search" /></form></div></section></div></div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="http://kerneltalks.com/" itemprop="item"><span itemprop="name">Home</span></a></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="http://kerneltalks.com/category/tips-tricks/" itemprop="item"><span itemprop="name">Tips &amp; Tricks</span></a></span> <span aria-label="breadcrumb separator">/</span> How to list open ports on Linux/Unix server</div><article class="post-1436 post type-post status-publish format-standard has-post-thumbnail category-tips-tricks tag-established-ports-in-linux tag-how-to-check-listening-ports-in-linux tag-list-all-ports-on-server-in-linux tag-open-ports-in-unix tag-open-sockets-in-linux entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to list open ports on Linux/Unix server</h1><p class="entry-meta">Last updated on <time class="entry-modified-time" itemprop="dateModified" datetime="2017-02-25T08:49:28+00:00">February 25, 2017</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://kerneltalks.com/author/shrikant/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Shrikant Lavhate</span></a></span> <span class="entry-comments-link"><a href="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/#respond">Leave a Comment</a></span></p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-small" id="share-before-1436"><div class="facebook" id="facebook-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="googlePlus" id="googleplus-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="twitter" id="twitter-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Tweet"></div><div class="linkedin" id="linkedin-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="stumbleupon" id="stumbleupon-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="pinterest" id="pinterest-before-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Pin"></div></div> <script type='text/javascript'>jQuery(document).ready(function($){$('#facebook-before-1436').sharrre({share:{facebook:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('facebook');}});$('#googleplus-before-1436').sharrre({share:{googlePlus:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('googlePlus');}});$('#twitter-before-1436').sharrre({share:{twitter:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{twitter:{via:'kerneltalks'}},click:function(api,options){api.simulateClick();api.openPopup('twitter');}});$('#linkedin-before-1436').sharrre({share:{linkedin:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('linkedin');}});$('#stumbleupon-before-1436').sharrre({share:{stumbleupon:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('stumbleupon');}});$('#pinterest-before-1436').sharrre({share:{pinterest:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{pinterest:{media:'http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png',description:'How to list open ports on Linux/Unix server'}},click:function(api,options){api.simulateClick();api.openPopup('pinterest');}});});</script><style>.kt_text{width:290px;height:90px}@media(min-width: 500px){.kt_text{width:268px;height:40px}}@media(min-width: 800px){.kt_text{width:528px;height:20px}}</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle kt_text" style="display:inline-block" data-ad-client="ca-pub-8607025047420953" data-ad-slot="3888649223" data-ad-format="link"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br /><hr /><p><em><img src="http://cdn2.kerneltalks.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-150x150.png" class="alignright size-thumbnail wp-image-1438" alt="List open ports in Linux Unix" width="150" height="150" srcset="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-150x150.png 150w, http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png 200w, http://cdn1.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-100x100.png 100w" sizes="(max-width: 150px) 100vw, 150px"><noscript><img class="alignright size-thumbnail wp-image-1438" src="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-150x150.png" alt="List open ports in Linux Unix" width="150" height="150" srcset="http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-150x150.png 150w, http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png 200w, http://cdn1.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix-100x100.png 100w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>Learn to list all open ports on Linux or Unix system. Also view associated process with them. Handy tip to troubleshoot service connectivity issues.</em></p><p>&nbsp;</p><hr /><p>Many times in life of sysadmin, you need to check which all ports open on your system. Sometimes you need to check if particular port is listening on server or not. If particular service is communicating on configured port or not. If particular port has established connection or not.</p><p>All these things can be analysed with below commands.</p><div class="insert-post-ads" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8607025047420953" data-ad-slot="4438770020" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> <br /></div><hr /><p><em><strong>netstat command :</strong></em></p><p>Obviously first command is none other than <em>netstat</em> command. Use netstat with 4 options :</p><ul><li>-a : Shows all sockets</li><li>-p : Show related PID</li><li>-t : TCP</li><li>-u : UDP</li></ul><p></p><div id="crayon-58b0f7c8031ea855745551" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;"><div class="crayon-toolbar" data-settings=" show" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span><div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div><div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div><div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">

# netstat -ptau
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:58573                     *:*                         LISTEN      1013/rpc.statd
tcp        0      0 *:sunrpc                    *:*                         LISTEN      991/rpcbind
tcp        0      0 *:ssh                       *:*                         LISTEN      1208/sshd
tcp        0      0 localhost:ipp               *:*                         LISTEN      1069/cupsd
tcp        0      0 localhost:smtp              *:*                         LISTEN      1287/master
tcp        0      0 ip-12-31-28-246.ap-:telnet 112.197.214.169:49648       ESTABLISHED 3213/in.telnetd
tcp        0      0 ip-12-31-28-246.ap-:telnet 200-163-187-49.scrce2:53440 ESTABLISHED 3215/in.telnetd
tcp        0      0 ip-12-31-28-246.ap-sou:ssh 59.182.17:49413             ESTABLISHED 1441/sshd
tcp        0    288 ip-12-31-28-246.ap-sou:ssh 59.182.17:50729             ESTABLISHED 1694/sshd
tcp        0      0 *:sunrpc                    *:*                         LISTEN      991/rpcbind
tcp        0      0 *:ssh                       *:*                         LISTEN      1208/sshd
tcp        0      0 *:telnet                    *:*                         LISTEN      1618/xinetd
tcp        0      0 localhost:ipp               *:*                         LISTEN      1069/cupsd
tcp        0      0 localhost:smtp              *:*                         LISTEN      1287/master
tcp        0      0 *:56954                     *:*                         LISTEN      1013/rpc.statd
udp        0      0 localhost:766               *:*                                     1013/rpc.statd
udp        0      0 *:39730                     *:*                                     1013/rpc.statd
udp        0      0 *:bootpc                    *:*                                     884/dhclient
udp        0      0 *:netrcs                    *:*                                     991/rpcbind
udp        0      0 *:sunrpc                    *:*                                     991/rpcbind
udp        0      0 *:ipp                       *:*                                     1069/cupsd
udp        0      0 *:60991                     *:*                                     1013/rpc.statd
udp        0      0 *:netrcs                    *:*                                     991/rpcbind
udp        0      0 *:sunrpc                    *:*                                     991/rpcbind
</textarea></div><div class="crayon-main" style=""><table class="crayon-table"><tr class="crayon-row"><td class="crayon-nums " data-settings="hide"><div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-2">2</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-4">4</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-6">6</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-8">8</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-10">10</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-12">12</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-14">14</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-16">16</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-18">18</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-20">20</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-22">22</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-24">24</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-26">26</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c8031ea855745551-28">28</div><div class="crayon-num" data-line="crayon-58b0f7c8031ea855745551-29">29</div></div></td><td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-1">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-2"><span class="crayon-c"># netstat -ptau</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-3"><span class="crayon-e">Active </span><span class="crayon-e">Internet </span><span class="crayon-e">connections</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-e">servers </span><span class="crayon-st">and</span><span class="crayon-h"> </span><span class="crayon-v">established</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-4"><span class="crayon-e">Proto </span><span class="crayon-v">Recv</span><span class="crayon-o">-</span><span class="crayon-i">Q</span><span class="crayon-h"> </span><span class="crayon-v">Send</span><span class="crayon-o">-</span><span class="crayon-i">Q</span><span class="crayon-h"> </span><span class="crayon-e">Local </span><span class="crayon-e">Address&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-e">Foreign </span><span class="crayon-e">Address&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-e">State&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-v">PID</span><span class="crayon-o">/</span><span class="crayon-e">Program </span><span class="crayon-e">name</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-5"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">58573</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1013</span><span class="crayon-o">/</span><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-6"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">sunrpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-e">rpcbind</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-7"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1208</span><span class="crayon-o">/</span><span class="crayon-e">sshd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-8"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-v">ipp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1069</span><span class="crayon-o">/</span><span class="crayon-e">cupsd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-9"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-v">smtp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1287</span><span class="crayon-o">/</span><span class="crayon-e">master</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-10"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-o">:</span><span class="crayon-i">telnet</span><span class="crayon-h"> </span><span class="crayon-cn">112.197.214.169</span><span class="crayon-o">:</span><span class="crayon-cn">49648</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">ESTABLISHED</span><span class="crayon-h"> </span><span class="crayon-cn">3213</span><span class="crayon-o">/</span><span class="crayon-st">in</span><span class="crayon-e">.telnetd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-11"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-o">:</span><span class="crayon-i">telnet</span><span class="crayon-h"> </span><span class="crayon-cn">200</span><span class="crayon-o">-</span><span class="crayon-cn">163</span><span class="crayon-o">-</span><span class="crayon-cn">187</span><span class="crayon-o">-</span><span class="crayon-cn">49.scrce2</span><span class="crayon-o">:</span><span class="crayon-cn">53440</span><span class="crayon-h"> </span><span class="crayon-i">ESTABLISHED</span><span class="crayon-h"> </span><span class="crayon-cn">3215</span><span class="crayon-o">/</span><span class="crayon-st">in</span><span class="crayon-e">.telnetd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-12"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">sou</span><span class="crayon-o">:</span><span class="crayon-i">ssh</span><span class="crayon-h"> </span><span class="crayon-cn">59.182.17</span><span class="crayon-o">:</span><span class="crayon-cn">49413</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">ESTABLISHED</span><span class="crayon-h"> </span><span class="crayon-cn">1441</span><span class="crayon-o">/</span><span class="crayon-e">sshd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-13"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">288</span><span class="crayon-h"> </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">sou</span><span class="crayon-o">:</span><span class="crayon-i">ssh</span><span class="crayon-h"> </span><span class="crayon-cn">59.182.17</span><span class="crayon-o">:</span><span class="crayon-cn">50729</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">ESTABLISHED</span><span class="crayon-h"> </span><span class="crayon-cn">1694</span><span class="crayon-o">/</span><span class="crayon-e">sshd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-14"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">sunrpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-e">rpcbind</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-15"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1208</span><span class="crayon-o">/</span><span class="crayon-e">sshd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-16"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1618</span><span class="crayon-o">/</span><span class="crayon-e">xinetd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-17"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-v">ipp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1069</span><span class="crayon-o">/</span><span class="crayon-e">cupsd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-18"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-v">smtp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1287</span><span class="crayon-o">/</span><span class="crayon-e">master</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-19"><span class="crayon-i">tcp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">56954</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">LISTEN</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1013</span><span class="crayon-o">/</span><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-20"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-cn">766</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1013</span><span class="crayon-o">/</span><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-21"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">39730</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1013</span><span class="crayon-o">/</span><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-22"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">bootpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">884</span><span class="crayon-o">/</span><span class="crayon-e">dhclient</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-23"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">netrcs</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-e">rpcbind</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-24"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">sunrpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-e">rpcbind</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-25"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">ipp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1069</span><span class="crayon-o">/</span><span class="crayon-e">cupsd</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-26"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">60991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1013</span><span class="crayon-o">/</span><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-27"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">netrcs</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-e">rpcbind</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c8031ea855745551-28"><span class="crayon-i">udp</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-v">sunrpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-o">*</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">991</span><span class="crayon-o">/</span><span class="crayon-i">rpcbind</span></div><div class="crayon-line" id="crayon-58b0f7c8031ea855745551-29">&nbsp;</div></div></td></tr></table></div></div><p>In above output you can see :</p><ul><li>First column is protocol</li><li>Forth column local address includes local IP, port, service</li><li>Fifth column destination IP, port etc</li><li>Sixth column is current state</li><li>Last column is PID and process name which owns that socket</li></ul><hr /><p><em><strong>lsof command :</strong></em></p><p>Using lsof command also you can trace current open ports on system. lsof mainely lists open files. Since sockets are treated as network files at kernel level and they are treated as open when communicating, sockets can be listed using lsof!</p><p>lsof has -i option specifically to list network files.</p><div id="crayon-58b0f7c803201005663417" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;"><div class="crayon-toolbar" data-settings=" show" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span><div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Toggle Line Numbers"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Toggle Plain Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Open Code In New Window"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div><div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div><div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">

# lsof -i
COMMAND    PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
dhclient   884     root    5u  IPv4  10791      0t0  UDP *:bootpc
rpcbind    991      rpc    6u  IPv4  11109      0t0  UDP *:sunrpc
rpcbind    991      rpc    7u  IPv4  11111      0t0  UDP *:netrcs
rpcbind    991      rpc    8u  IPv4  11112      0t0  TCP *:sunrpc (LISTEN)
rpcbind    991      rpc    9u  IPv6  11114      0t0  UDP *:sunrpc
rpcbind    991      rpc   10u  IPv6  11116      0t0  UDP *:netrcs
rpcbind    991      rpc   11u  IPv6  11117      0t0  TCP *:sunrpc (LISTEN)
rpc.statd 1013  rpcuser    6u  IPv4  11206      0t0  UDP localhost:766
rpc.statd 1013  rpcuser    7u  IPv4  11210      0t0  UDP *:39730
rpc.statd 1013  rpcuser    8u  IPv4  11214      0t0  TCP *:58573 (LISTEN)
rpc.statd 1013  rpcuser    9u  IPv6  11218      0t0  UDP *:60991
rpc.statd 1013  rpcuser   10u  IPv6  11222      0t0  TCP *:56954 (LISTEN)
cupsd     1069     root    6u  IPv6  11412      0t0  TCP localhost:ipp (LISTEN)
cupsd     1069     root    7u  IPv4  11413      0t0  TCP localhost:ipp (LISTEN)
cupsd     1069     root    9u  IPv4  11416      0t0  UDP *:ipp
sshd      1208     root    3u  IPv4  11960      0t0  TCP *:ssh (LISTEN)
sshd      1208     root    4u  IPv6  11962      0t0  TCP *:ssh (LISTEN)
master    1287     root   11u  IPv4  12158      0t0  TCP localhost:smtp (LISTEN)
master    1287     root   12u  IPv6  12160      0t0  TCP localhost:smtp (LISTEN)
sshd      1441     root    3r  IPv4  12964      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:ssh-59.184.179.68:49413 (ESTABLISHED)
sshd      1444 ec2-user    3u  IPv4  12964      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:ssh-59.184.179.68:49413 (ESTABLISHED)
xinetd    1618     root    5u  IPv6  13908      0t0  TCP *:telnet (LISTEN)
sshd      1694     root    3r  IPv4  14812      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:ssh-59.184.179.68:50729 (ESTABLISHED)
sshd      1697 ec2-user    3u  IPv4  14812      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:ssh-59.184.179.68:50729 (ESTABLISHED)
in.telnet 3420     root    0u  IPv4  35294      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;5ec3c900.skybroadband.com:39192 (ESTABLISHED)
in.telnet 3420     root    1u  IPv4  35294      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;5ec3c900.skybroadband.com:39192 (ESTABLISHED)
in.telnet 3420     root    2u  IPv4  35294      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;5ec3c900.skybroadband.com:39192 (ESTABLISHED)
in.telnet 3422     root    0u  IPv4  35326      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;188-24-133-29.dynamic.brasov.rdsnet.ro:apwi-rxserver (ESTABLISHED)
in.telnet 3422     root    1u  IPv4  35326      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;188-24-133-29.dynamic.brasov.rdsnet.ro:apwi-rxserver (ESTABLISHED)
in.telnet 3422     root    2u  IPv4  35326      0t0  TCP ip-12-31-28-246.ap-south-1.compute.internal:telnet-&gt;188-24-133-29.dynamic.brasov.rdsnet.ro:apwi-rxserver (ESTABLISHED)
</textarea></div><div class="crayon-main" style=""><table class="crayon-table"><tr class="crayon-row"><td class="crayon-nums " data-settings="hide"><div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-2">2</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-4">4</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-6">6</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-8">8</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-10">10</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-12">12</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-14">14</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-16">16</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-18">18</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-20">20</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-22">22</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-24">24</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-26">26</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-28">28</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-29">29</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-30">30</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-31">31</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-32">32</div><div class="crayon-num" data-line="crayon-58b0f7c803201005663417-33">33</div><div class="crayon-num crayon-striped-num" data-line="crayon-58b0f7c803201005663417-34">34</div></div></td><td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-58b0f7c803201005663417-1">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-2"><span class="crayon-c"># lsof -i</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-3"><span class="crayon-r">COMMAND</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">PID&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-e">USER&nbsp;&nbsp; </span><span class="crayon-e">FD&nbsp;&nbsp; </span><span class="crayon-r">TYPE</span><span class="crayon-h"> </span><span class="crayon-e">DEVICE </span><span class="crayon-v">SIZE</span><span class="crayon-o">/</span><span class="crayon-e">OFF </span><span class="crayon-e">NODE </span><span class="crayon-e">NAME</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-4"><span class="crayon-i">dhclient</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">884</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">5u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">10791</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">bootpc</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-5"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">6u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11109</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">sunrpc</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-6"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">7u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11111</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">netrcs</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-7"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">8u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11112</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">sunrpc</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-8"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">9u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11114</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">sunrpc</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-9"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">10u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11116</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">netrcs</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-10"><span class="crayon-i">rpcbind</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">991</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">rpc</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">11u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11117</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">sunrpc</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-11"><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span><span class="crayon-h"> </span><span class="crayon-cn">1013</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">rpcuser</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">6u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11206</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">UDP </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-cn">766</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-12"><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span><span class="crayon-h"> </span><span class="crayon-cn">1013</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">rpcuser</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">7u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11210</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">39730</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-13"><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span><span class="crayon-h"> </span><span class="crayon-cn">1013</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">rpcuser</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">8u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11214</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">58573</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-14"><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span><span class="crayon-h"> </span><span class="crayon-cn">1013</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">rpcuser</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">9u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11218</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">60991</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-15"><span class="crayon-v">rpc</span><span class="crayon-e">.statd</span><span class="crayon-h"> </span><span class="crayon-cn">1013</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">rpcuser</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">10u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11222</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-cn">56954</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-16"><span class="crayon-i">cupsd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1069</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">6u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11412</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-e">ipp</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-17"><span class="crayon-i">cupsd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1069</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">7u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11413</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-e">ipp</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-18"><span class="crayon-i">cupsd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1069</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">9u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11416</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">UDP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">ipp</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-19"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1208</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">3u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11960</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">ssh</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-20"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1208</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">4u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">11962</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">ssh</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-21"><span class="crayon-i">master</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1287</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">11u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">12158</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-e">smtp</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-22"><span class="crayon-i">master</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1287</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-cn">12u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">12160</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">localhost</span><span class="crayon-o">:</span><span class="crayon-e">smtp</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-23"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1441</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">3r</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">12964</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-o">-</span><span class="crayon-cn">59.184.179.68</span><span class="crayon-o">:</span><span class="crayon-cn">49413</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-24"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1444</span><span class="crayon-h"> </span><span class="crayon-v">ec2</span><span class="crayon-o">-</span><span class="crayon-i">user</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">3u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">12964</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-o">-</span><span class="crayon-cn">59.184.179.68</span><span class="crayon-o">:</span><span class="crayon-cn">49413</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-25"><span class="crayon-i">xinetd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1618</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">5u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv6</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">13908</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">TCP</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-o">:</span><span class="crayon-e">telnet</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">LISTEN</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-26"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1694</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">3r</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">14812</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-o">-</span><span class="crayon-cn">59.184.179.68</span><span class="crayon-o">:</span><span class="crayon-cn">50729</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-27"><span class="crayon-i">sshd</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1697</span><span class="crayon-h"> </span><span class="crayon-v">ec2</span><span class="crayon-o">-</span><span class="crayon-i">user</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">3u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">14812</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">ssh</span><span class="crayon-o">-</span><span class="crayon-cn">59.184.179.68</span><span class="crayon-o">:</span><span class="crayon-cn">50729</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-28"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3420</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35294</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">5ec3c900.skybroadband.com</span><span class="crayon-o">:</span><span class="crayon-cn">39192</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-29"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3420</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35294</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">5ec3c900.skybroadband.com</span><span class="crayon-o">:</span><span class="crayon-cn">39192</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-30"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3420</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">2u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35294</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">5ec3c900.skybroadband.com</span><span class="crayon-o">:</span><span class="crayon-cn">39192</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-31"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3422</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35326</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">188</span><span class="crayon-o">-</span><span class="crayon-cn">24</span><span class="crayon-o">-</span><span class="crayon-cn">133</span><span class="crayon-o">-</span><span class="crayon-cn">29.dynamic.brasov.rdsnet.ro</span><span class="crayon-o">:</span><span class="crayon-v">apwi</span><span class="crayon-o">-</span><span class="crayon-e">rxserver</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-32"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3422</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">1u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35326</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">188</span><span class="crayon-o">-</span><span class="crayon-cn">24</span><span class="crayon-o">-</span><span class="crayon-cn">133</span><span class="crayon-o">-</span><span class="crayon-cn">29.dynamic.brasov.rdsnet.ro</span><span class="crayon-o">:</span><span class="crayon-v">apwi</span><span class="crayon-o">-</span><span class="crayon-e">rxserver</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-58b0f7c803201005663417-33"><span class="crayon-st">in</span><span class="crayon-e">.telnet</span><span class="crayon-h"> </span><span class="crayon-cn">3422</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-i">root</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">2u</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">IPv4</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">35326</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-cn">0t0</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">TCP </span><span class="crayon-v">ip</span><span class="crayon-o">-</span><span class="crayon-cn">12</span><span class="crayon-o">-</span><span class="crayon-cn">31</span><span class="crayon-o">-</span><span class="crayon-cn">28</span><span class="crayon-o">-</span><span class="crayon-cn">246.ap</span><span class="crayon-o">-</span><span class="crayon-v">south</span><span class="crayon-o">-</span><span class="crayon-cn">1.compute.internal</span><span class="crayon-o">:</span><span class="crayon-v">telnet</span><span class="crayon-o">-&gt;</span><span class="crayon-cn">188</span><span class="crayon-o">-</span><span class="crayon-cn">24</span><span class="crayon-o">-</span><span class="crayon-cn">133</span><span class="crayon-o">-</span><span class="crayon-cn">29.dynamic.brasov.rdsnet.ro</span><span class="crayon-o">:</span><span class="crayon-v">apwi</span><span class="crayon-o">-</span><span class="crayon-e">rxserver</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">ESTABLISHED</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-58b0f7c803201005663417-34">&nbsp;</div></div></td></tr></table></div></div><p>In above output you can see which command being run by which user using which socket and state of port at the end!</p><hr /><p>If you have any other trick to list open ports on system, please let us know in comments. We will add it to this post.</p><div class="share-after share-filled share-small" id="share-after-1436"><div class="facebook" id="facebook-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="googlePlus" id="googleplus-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="twitter" id="twitter-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Tweet"></div><div class="linkedin" id="linkedin-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="stumbleupon" id="stumbleupon-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Share"></div><div class="pinterest" id="pinterest-after-1436" data-url="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" data-urlalt="http://kerneltalks.com/?p=1436" data-text="How to list open ports on Linux/Unix server" data-title="Pin"></div></div> <script type='text/javascript'>jQuery(document).ready(function($){$('#facebook-after-1436').sharrre({share:{facebook:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('facebook');}});$('#googleplus-after-1436').sharrre({share:{googlePlus:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('googlePlus');}});$('#twitter-after-1436').sharrre({share:{twitter:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{twitter:{via:'kerneltalks'}},click:function(api,options){api.simulateClick();api.openPopup('twitter');}});$('#linkedin-after-1436').sharrre({share:{linkedin:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('linkedin');}});$('#stumbleupon-after-1436').sharrre({share:{stumbleupon:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{},click:function(api,options){api.simulateClick();api.openPopup('stumbleupon');}});$('#pinterest-after-1436').sharrre({share:{pinterest:true},urlCurl:'http://kerneltalks.com/wp-content/plugins/genesis-simple-share/lib/sharrre/sharrre.php',enableHover:false,enableTracking:true,buttons:{pinterest:{media:'http://cdn2.kerneltalks.com/wp-content/uploads/2017/02/List-open-ports-in-Linux-Unix.png',description:'How to list open ports on Linux/Unix server'}},click:function(api,options){api.simulateClick();api.openPopup('pinterest');}});});</script></div><div><h3>Related stuff:</h3><ul class="myrelated"><li><a href="http://kerneltalks.com/howto/howto-get-directory-size-linux/" rel="bookmark" title="Link to How to get directory size in Linux">How to get directory size in Linux</a></li><li><a href="http://kerneltalks.com/scripts/3-ways-get-multiple-commands-output-row/" rel="bookmark" title="Link to 3 tricks to get multiple commands output in same row">3 tricks to get multiple commands output in same row</a></li><li><a href="http://kerneltalks.com/howto/run-command-on-multiple-linux-servers-from-windows/" rel="bookmark" title="Link to Run command on multiple linux servers from windows">Run command on multiple linux servers from windows</a></li></ul></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://kerneltalks.com/category/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></span> <span class="entry-tags">Tagged With: <a href="http://kerneltalks.com/tag/established-ports-in-linux/" rel="tag">established ports in linux</a>, <a href="http://kerneltalks.com/tag/how-to-check-listening-ports-in-linux/" rel="tag">how to check listening ports in linux</a>, <a href="http://kerneltalks.com/tag/list-all-ports-on-server-in-linux/" rel="tag">list all ports on server in linux</a>, <a href="http://kerneltalks.com/tag/open-ports-in-unix/" rel="tag">open ports in unix</a>, <a href="http://kerneltalks.com/tag/open-sockets-in-linux/" rel="tag">open sockets in linux</a></span></p><div class="mybox"><h4 class="belowposthead">If you like my tutorials and if they helped you in any way, you should</h4><ul class="belowpost"><li>Consider buying me <a class="abelow" href="http://kerneltalks.com/buy-me-coffee/">a cup of coffee via paypal</a>!</li><li>Like KernelTalks <a class="abelow" href="https://www.facebook.com/kerneltalks">Facebook page</a>.</li><li>Follow us on <a class="abelow" href="https://twitter.com/@kerneltalks">Twitter</a>.</li><li>Follow our <a class="abelow" href="https://plus.google.com/b/115086199909589647244/115086199909589647244">Google+ page</a>.</li><li>Add our <a class="abelow" href="http://feeds.feedburner.com/kerneltalks">RSS feed</a> to your feed reader.</li></ul></div></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Any thoughts? <small><a rel="nofollow" id="cancel-comment-reply-link" href="/tips-tricks/list-open-ports-linux-server/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=118008198&#038;postid=1436&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Any+thoughts%3F&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=3c8b1d8d13fceaea04e5703909f0556bebcb0449#parent=http%3A%2F%2Fkerneltalks.com%2Ftips-tricks%2Flist-open-ports-linux-server%2F" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe></form></div> <input type="hidden" name="comment_parent" id="comment_parent" value="" /></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-facebook"><a href="https://www.facebook.com/kerneltalks" target="_blank"><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="http://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/b/115086199909589647244/115086199909589647244" target="_blank"><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="http://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-rss"><a href="http://feeds.feedburner.com/kerneltalks" target="_blank"><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="http://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/@kerneltalks" target="_blank"><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="http://kerneltalks.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section> <section id="text-10" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-8607025047420953" data-ad-slot="8007133228"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id="text-9" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8607025047420953" data-ad-slot="2693168428" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div></section> <section id="blog_subscription-2" class="widget jetpack_subscription_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Subscribe</h4><form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2"><div id="subscribe-text"><p>Get Linux &amp; Unix stuff right into your mailbox! It's FREE</p></div><p>Join 43 other subscribers</p><p id="subscribe-email"> <label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2"> Email Address						</label> <input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" /></p><p id="subscribe-submit"> <input type="hidden" name="action" value="subscribe" /> <input type="hidden" name="source" value="http://kerneltalks.com/tips-tricks/list-open-ports-linux-server/" /> <input type="hidden" name="sub-type" value="widget" /> <input type="hidden" name="redirect_fragment" value="blog_subscription-2" /> <input type="submit" value="I&#039;m in" name="jetpack_subscriptions_widget" /></p></form> <script>(function(d){if(('placeholder'in d.createElement('input'))){var label=d.querySelector('label[for=subscribe-field-blog_subscription-2]');label.style.clip='rect(1px, 1px, 1px, 1px)';label.style.position='absolute';label.style.height='1px';label.style.width='1px';label.style.overflow='hidden';}
var form=d.getElementById('subscribe-blog-blog_subscription-2'),input=d.getElementById('subscribe-field-blog_subscription-2'),handler=function(event){if(''===input.value){input.focus();if(event.preventDefault){event.preventDefault();}
return false;}};if(window.addEventListener){form.addEventListener('submit',handler,false);}else{form.attachEvent('onsubmit',handler);}})(document);</script> </div></section> </aside></div></div><style>.kernel_footer{width:290px;height:90px}@media(min-width: 500px){.kernel_footer{width:468px;height:60px}}@media(min-width: 800px){.kernel_footer{width:728px;height:90px}}</style><center <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle kernel_footer" style="display:inline-block" data-ad-client="ca-pub-8607025047420953" data-ad-slot="4467072020" data-ad-format="auto"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </center><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>&copy; Copyright 2016-2017 <a href="http://kerneltalks.com/">KernelTalks</a> &middot; All Rights Reserved &middot; The content is copyrighted to Shrikant Lavhate and may not be reproduced on other websites.</p></div></footer></div><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-85401996-1','auto');ga('send','pageview');</script> <script type="text/javascript" src="http://cdn1.kerneltalks.com/wp-content/cache/minify/5b374.js"></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type="text/javascript" src="http://cdn1.kerneltalks.com/wp-content/cache/minify/2fb31.js"></script> <script type='text/javascript'>var q2w3_sidebar_options=new Array();q2w3_sidebar_options[0]={"sidebar":"sidebar","margin_top":70,"margin_bottom":205,"stop_id":"ad_unit","screen_max_width":800,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":['blog_subscription-2']};</script> <script type="text/javascript" src="http://cdn1.kerneltalks.com/wp-content/cache/minify/10927.js"></script> <!--[if IE]> <script type="text/javascript">if(0===window.location.hash.indexOf('#comment-')){window.location.hash=window.location.hash;}</script> <![endif]--> <script type="text/javascript">/*<![CDATA[*/var comm_par_el=document.getElementById('comment_parent'),comm_par=(comm_par_el&&comm_par_el.value)?comm_par_el.value:'',frame=document.getElementById('jetpack_remote_comment'),tellFrameNewParent;tellFrameNewParent=function(){if(comm_par){frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=118008198&postid=1436&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Any+thoughts%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=3c8b1d8d13fceaea04e5703909f0556bebcb0449#parent=http%3A%2F%2Fkerneltalks.com%2Ftips-tricks%2Flist-open-ports-linux-server%2F"+'&replytocom='+parseInt(comm_par,10).toString();}else{frame.src="https://jetpack.wordpress.com/jetpack-comment/?blogid=118008198&postid=1436&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Any+thoughts%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=3c8b1d8d13fceaea04e5703909f0556bebcb0449#parent=http%3A%2F%2Fkerneltalks.com%2Ftips-tricks%2Flist-open-ports-linux-server%2F";}};if('undefined'!==typeof addComment){addComment._Jetpack_moveForm=addComment.moveForm;addComment.moveForm=function(commId,parentId,respondId,postId){var returnValue=addComment._Jetpack_moveForm(commId,parentId,respondId,postId),cancelClick,cancel;if(false===returnValue){cancel=document.getElementById('cancel-comment-reply-link');cancelClick=cancel.onclick;cancel.onclick=function(){var cancelReturn=cancelClick.call(this);if(false!==cancelReturn){return cancelReturn;}
if(!comm_par){return cancelReturn;}
comm_par=0;tellFrameNewParent();return cancelReturn;};}
if(comm_par==parentId){return returnValue;}
comm_par=parentId;tellFrameNewParent();return returnValue;};}
if(window.postMessage){if(document.addEventListener){window.addEventListener('message',function(event){if("https:\/\/jetpack.wordpress.com"!==event.origin){return;}
jQuery(frame).height(event.data);});}else if(document.attachEvent){window.attachEvent('message',function(event){if("https:\/\/jetpack.wordpress.com"!==event.origin){return;}
jQuery(frame).height(event.data);});}}/*]]>*/</script> <script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:4.6',blog:'118008198',post:'1436',tz:'5.5',srv:'kerneltalks.com'}]);_stq.push(['clickTrackerInit','118008198','1436']);</script> </body></html>